Course Pages Not Loading

6 of my 11 courses here on load to a blank white page. I am currently unable to access any of the lectures for those courses, including one of which I have already completed and trying to review certain lessons. This has happened more than once now and rather frustrating as I can’t progress with my project.


I just tried a random lecture and it opened for me. So I am guessing it is a local issue.

I assume it is not your internet or connection, and other things work ok?

Have you tried a different browser, I used Chrome.

Is there anything else you can notice that may help for me to pass onto the staff that have some chance of looking into this? Particular courses? Particular times of day? What browser you tried?
Are you located somewhere that may have some poor connections, restrictions, or such issues?

I am not site tech, but I imagine if it is working for everyone else, we need to work out what is different about your experience, as it seems unlikely to be an issue at the site itself, or there would be lot a of mentions! Just checked the Discord and I do not see any mentions of trouble mentioned there.


Just wanted to quickly mention that ad blockers and in-browser security settings can also play a big role here. I have 3 different extensions for privacy and ad-blocking, and I think I had to make exceptions in 2 of the 3 and reduce Firefox security from strict to standard before anything would load (something along those lines anyway).

Pretty certain it’s not the site itself though, as I’ve had no problems since. Hopefully that’s good news, as it means you’ll most likely be in control of the eventual solution (vs. waiting for a site update for example). Good luck! =)

1 Like

My internet is working fine as far as I can tell; no issue with other sites I regularly use. And to be clear, the other 5 course pages do load and seem to work properly.

I am using Google Chrome. I will try a different browser later. I did have an adblock enabled, but turning it off has not yielded any different result.

As for particular things, I have not noticed any reoccuring patterns regarding the issue. No recent hardware or software changes on my computer that I’m aware of. It has happened randomly and the previous times it has resolved itself after a while.

I found a recent community post that sounds like a similar situation. Here’s the link to that Can't access any of my courses
Maybe similar case?

The following are the courses that are not loading for me:

Geometry Nodes in Blender 4: Create Complex 3D Models
Blender Animation & Rigging: Bring Your Creations To Life
Blender 4 Sculpting Brushes: Create Amazing Sculpts Quickly
Blender Material Nodes Mastery: Create Spectacular Textures
Anime Character Creator: Make 3D Anime Charaters in Blender
Blender Texture Painting: Create Stunning Stylised Models



It can be trouble some when accessing the course via a different login route (Using GameDev, Or via Udemy, Or (what I do) using GitHub SSO

1 Like

I had this problem too. It was that my security & privacy->Safe Browsing was set to enhanced. I had to change it to standard. Until I figured it out I was using Firefox.

1 Like


I have just tested using Firefox today and it appears to work fine, videos play and everything.

Now that I can actually access the courses on Firefox, I did notice something, and that is all the courses that I’ve been having issue with have a ‘landing page’ that they load to first, before the page with all the videos.

All the courses that link to this white landing page do not load in Chrome:

All the courses that link directly to the video page are able to load in Chrome:

Not exactly resolved, but at least I can continue now.


Okay I just went to check the safe browsing setting and its already set to standard, so that didn’t help. But thanks anyway.


Privacy & Terms