First is pure pedantry. As we are fixing naming convention issues in this lecture, I assume the _currentDirection float in Enemy should be renamed currentDirection as it is no longer a class reference.
Secondly, while we have extracted the lateral movement out of the controls, we still have the jumps in there. This may be looked at in the double jump lecture, but I guess that this should also be refactored out at some point, thereby being able to remove _rigidBody from PlayerController and Enemy?