"CoreMinimal.h" not found

Going through C++ Unreal udemy course, “ObstacleAssault” section.

Rebuilt files, Rebuilt VS Code Project. “CoreMinimal.h” still not found.

Mac M2 Pro UE 5.3

You appear to be using a build task generated by VS Code that is just trying to compile the active file. You need to use the build tasks Unreal will generate.

Do Tools > Refresh VS Code project in Unreal (will probably be slightly different with the toolbar in macOS). Then use the build task “ProjectNameEditor Mac Development Build”

Thank you for your help! That seemed to resolve the missing header issue. Although I’m seeing a few other issues.

I’m suspect that the setup of my environment is incorrect. For one my intellisense doesn’t seem to be working correctly and previously I’ve been having high compile times within the editor…

I recently found this link, granted most of the instructions are geared towards windows users but are most of the carry overs the same for a mac environment, if not which ones should be augmented? Unreal Docs

Could you give examples? What does your VS Code window look like? Anything in the Problems tab?

Hello DanM,
Am still facing the issue . i tried installing the UE in external and refreshed VS code, and after internal ssd and did the same.

Got to know that, if in extensions, Microsoft c++ and clangd both extensions are enabled, then by disabling clangd extension errs are now resolved!

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms