Hello there !

This is kinda offtopic but I think it is a useful thing to know for the future.

At minute 4:39, the selected (active) object has a default gray color brighter than the inactive object which makes it more pleasing for the eye:

The default colors are not like this:

Any idea how to change that ? I searched the web and I got nothing.

I looked in the settings (Edit → Preferences → Themes → 3D Viewport) and Viewport Shading as well but I can’t find a solution.

Viewport Shading → Color → Single can modify the default object color but it does that to all objects, both active and inactive, it would be nice to be able to modify the color just for the active as in the video (first image ^).

Thanks !

1 Like

The grey face variations, are a way for Blender to communicate with you.
Hard to see sometimes, you need a bit of experience.

  • Most probably cause, is that you inverted a single, or multiple faces.
  • Or face managed, manipulated … etc.

Basically, a face has only one visible side. The other size is transparent!
But Blender ignores this rule (only game engines do), but will give it a different grey color.

The front of a face is marked with a ‘Normal’ line. By default, this is turned off!
Or you switch on the ‘Face’ direction color. As seen below image

Red means inside out, Blue is good, the front of a face.

  • In edit mode, select all mesh and press hotkey Shift n.

The selected face, or faces, are ‘illuminated’ already, standard Blender visual aid to see they are selected. I am unsure as to what different you are aiming for.

Ultimately you can colour every face a different colour if you can be bothered. Just in this viewport colouring, or the main proper one used for rendered views.

Perhaps you have not got to the texturing parts of the course yet? More understanding of multiple colours on one object etc.

1 Like

Hello again,

While I was preparing another two screenshots for further explanation, I stumbled upon the solution !

It has nothing to do with the orientation of the normals nor the color (material) but it’s about the display of the default geometry.

I wanted this:

(observe the difference of the gray shading between active and inactive objects)

I had this:

(observe the same shading of gray both on active and inactive objects)

And the solution is to switch on the ‘Fade Inactive Geometry’ option found in Viewport Overlays → Geometry (in Edit Mode):

I find this option, pretty useful !

Thank you for the replies, @FedPete and @NP5 !


Well done finding what worked for you.
Must say I have never noticed or wanted this option but that is the beauty of Blender so many options to fit different users.


Thanks !

Yes, it is nice that Blender is very customizable.
I find this option pretty helpful for the eyes. :slight_smile:


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms