Collision handling override to "Always spawn, ignore collision" does not work

When I keep the Cannon mesh collision to Block all , and at the spawn actor node use the always spawn for collision handling, the projectile doesn’t fire from cannon, but when I change the cannon mesh collision to noCollision it works, any idea why the first method doesn’t work?

Here is my blueprint :

Perhaps you are spawning the projectile too close to the cannon and the two mesh collision interfere with each other?

Yea when I move it further away it works, but isn’t that " always spawn " option suppose to spawn the projectiles if they are even too close?

I don’t know. It worked for me when I did this, but I really don’t understand why, only there was a problem with the two colliders.