CL Not Working for me either. HALP!

Hello Everyone!

I am BRAND NEW at this. I am using windows 10.
As I have been following along, step by step, I am also encountering an error during the CL process.

The error I’m getting is "Fatal Error LNK1104: Cannot Open File ‘kernel32.lib’ "

I have included screenshots of the process up to the error(s)

Thank you everyone. I look forward to your feedback.







Did you install Visual Studio Community with the following settings?

1 Like

I just double-checked, and the only thing I didn’t have ticked was “Unreal Engine Installer”, but everything else was ticked.

Now, I am getting the error; " ‘cl’ is not recognized as an internal or external command, operable program or batch file."

I also had some install issues; I recommend double-checking this list (it’s long) and following it to the letter:

using Unreal Engine 4.27.1, and Visual Studio 2019.

ALSO - defining your acronyms while on message board and/or when asking for help cuts down on confusion dramatically.

Thank you for the helpful information. I went for it and went step by step. Unfortunately, I’m still having the same issue in that VS Code is still not compiling. So I’m trying different things, looking at different messages to see if anyone else has the same issue and has fixed it, but so far nothing has been working for me.

Did you try to find “kernal32.lib” and make sure Visual Studio knows where it is?

It’s possible a directory is set incorrectly in settings, or a file is corrupted.

This might help:

I got everything running now. Thank you for following up. :sunglasses:

1 Like

Good to hear!
What did it?

Hello! I’m having the same error as you were having. What fixed your problem? I’m hoping the same thing will work for me.

Thank you!