Cinematic actor always visible

I saw the previous question and its solution “Had to check ‘Actor Hidden In Game’ for the Capsule Component of the cinematic player blueprint, in the Details panel. (the one, that’s next to the Outliner; not inside the BP)”.
I’ve tried it and didn’t work. You were mentioning that multiple people had that problem udemy. Do you know of any other solution please?

If I eject while playing (f8) and set the actor hidden in game field, it works. But without ejecting it can’t remember that it should be hidden. It looks like something is always overriding it when the game starts.

It makes sense that it doesn’t stick when you change it while the game is running as those changes don’t stay once you stop.

If the concern is that something is overriding it, then you’ll need to dig through your code for the actor and see what is setting that value. Focus on Begin Play and Construction.

I just have to turn it off and on again several times and it starts to work. And if I change something in the sequence, I have to turn it off and on again several more times to make it work.

I’ve tried being in the sequencer, being in the content browser, being in the sequencer in the timeline before the animation where the Actor Hidden In Game is set to true, I tried anything I could think of.

But I couldn’t figure out the “rule”.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms