Chess Texture not showing

@irresistiblejelly
Here is the scene, I can’t figure out why the texture on the board doesn’t appear to be working.Chess Scene.blend (1.7 MB)

Before I give you the wrong solution, are you using v2.80 or a 2.7x version?

2.8

Fastest way to do this i think in eevee is not using that texture panel at all.
If you create a new material on the board surround and then click the dot next to the base colour and change that to the image you want to use then it should add the texture.
This wont be mapped as we havent uv unwrapped but in the absence of this lecture being in 2.8 that be the way i would do it as a work around rather than introducing you to the node editor this early on.

Mikey will have a plan to teach this though.

Hope this helps

I tried that since I saw somebody else suggested it, but the image is warped and unnatural. Also, on the Bone Constraints matter, your solution did allow me to move further than 180 degrees on the axis but it still snaps back in the minimum angle after that.

The chess board at this point in time will be warped and look odd as we have just thrown the texture onto the model.
When the board was made it comes with a UV map which remained the UV map as it was before the board was modified. So now you have a board with the UV mapping to its old shape.
Basically UV maps are the model cut up and led flat out and we link that in to tell the texture where we want it to go.

If you think of it like a chocolate santa, You lay the foil out flat and that is the texture, Now look at the chocolate santa as if its a model and those vertices line up on the UV map so where we put the UV map over the texture is where the texture displays.

We can edit UV maps as well to position them better and even scale them so they look correct.

This is why we cover UV mapping a bit later in the course although as i dont know where Mikey plans to teach it yet i dont want to overwhelm you too much to find Mikey teaches it three sections on.

Lamp

I would go though the video again just watching to see if anything triggers on that.
Also below the video window when you are not in full screen you can go to the lectures and click the folder icon at the end of the row of the lecture you are on.
There is a link to the project changes.
If you click view file on the blend file (i think from memory) then you can download Mikey’s version of the file and open it to compare.

Be warned though if you open the 2.79 file in 2.8 it may not work so you may need to install 2.79 to compare and work around the differences.
From what i remember of the dinosaur i did in 2.8 from a 2.79 the differences were minimal as i havent tried the lamp in 2.8 yet

Hope this helps and let me know if you find anything or you get things solved :slight_smile:

So. about the texture, I should watch some videos on UV mapping, right?
On the lamp issue, I downloaded Mike’s file, but the problem remains, it is even stranger because the lamp rotates as if snapping to something that isn’t there and behaves like my own, except for both minimum and maximum angles. I mean that when I rotate it past the minimum it goes back at the maximum angle and vice versa, instead of only doing that for the maximum angle. I checked and set it at local space as well.

P.S. Never mind about the weird snapping, I rewatched the constraint video and realised it was covered in that.

1 Like

Yes, we do cover it here in the game asset section but i offhand cant remember the lecture
Theres some blender guru ones that help as well on hard surface uv unwrapping which is what you will need, Things get a little more complex with organic modelling but still basic concepts followed.

So the snapping is resolved on the animated lamp now it was the constraints there.
So can you just clarify for me that this also has been solved or is it still having an issue?

If its having an issue upload that file and i can take a look too :slight_smile:

Edit :- Found the other thread on the lamp and replied there.
I’ll mark this one as solved with the UV videos as a solution :slight_smile:

No, the random snapping on Mike’s lamp was resolved, since he didn’t upload it with local space and that was causing the lamp to snap at random points during rotation, just like it did in the lecture. My problem still remains, and it is that after I rotate past 180 degrees on the local axis of the bone, instead of it continuing the rotation and remaining stationary after maximum like it does in the video, it instead snaps back at the minimum angle. For example, if I set the minimum angle at -10 and maximum at 210, when I rotate past 180 it should keep going and stop at 210, but instead it snaps back at -10.

Yeah, I think the textures problem is solved, I was just too lazy to take the conversation to the other thread xD.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.