Changing VS code compiler from 2019 to 2022

I am trying to compile to moving platform.h and it does succeed but using VS 2019.
I have both of them 2022 & 2019 and for the life of me I can’t make the project to be compiled under 2022! Please assist. I’ve change the compiler path like everywhere.

Hi Offir,

Is there a specific reason you need to be using 2019?
My solution would be if you dont need to use 2019 would be to uninstall it that way it only has 2022 to use.
As far as i remember you have to change it in the project settings so make sure it is changed there (Probably an obvious thing) but this is my only real suggestion to solve this at the moment

Ty for a super quick reply!
Though I do not use VS 2019, but as I said. Compilation was successful using VS 2019 I fear that if I uninstall it, it will mess up things even more.
I’ll try changing the project settings inside unreal first and see what it does

You don’t have to uninstall 2019 unless disk space is an issue. I have 2017,2019 and 2022 all on my PC because I needed tools from 2015 (also in 2017)

You can easily have 2019 and 2022 side by side and 2022 is a little faster to use so is worth switching.

1 Like

Ty guys! I ended up uninstalling 2019. After that VS code went to compile using 2022.
Thanks again for the help

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms