Cavity map error

Hello friends!
I again don’t know what’s wrong with my work. My cavity map is also not coming out well. I am trying the same thing for the past 2 days, but still standing in same place. This is my output image. Since this is my first project, I am unable to guess what’s going on… A helping hand would be more appreciated. Thanks in advance.

1 Like

Use extrusion, the parameter above Ray Distance.
You can probably set Ray distance at zero.
Extrusion at 0.001 and experiment from there.

  1. You haven’t saved your texture. I can tell because on the texture node color space it’s grayed out.
  2. Did you setup the the highpoly material (Pointiness to color ramp to base color)?
  3. Was cavity texture and normal map texture disconnected before clicking the bake button?
  4. Is bake type set to diffuse and did you turn off direct and indirect? Only color should be on.
  5. If you have view from option make sure it’s Above surface.
  6. If you’re using GPU, try using CPU. Sometimes GPU glitches.
    It would help to see a screenshot of just the highpoly in render view so we can see what your cavity is suppose to look like.

Here is the screenshot of the High poly version page.

Thank you so much. :slightly_smiling_face: I started experimenting by keeping ray distance at 0 and changing the values of the extrusion starting from .001 trying up to .02 each time by slightly pushing here and there the value of color ramp (for the high poly version). I got this output for ray distance 0; extrusion .02; and color ramp values (436, 591)(for the high poly version). Please let me know if I have to do any changes in this. Thanks again.


Looks good to me.

1 Like

Great, well done playing with the parameters. It works, so it is good. There is no ‘right’ numbers I could give you as every model will vary. Result looks fine.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms