Canvas and Game zoomed in within WebGl Build

Hey all,

So I’m trying to publish a WebGL version of my Argon Assault game but something weird is happening. The canvas seems to be a bit stretched and the game seems to be zoomed in a bit. In the player settings before building, I set the build to be 1028 x 768, like in my game window, however, it still appears to be zoomed in. I’m not sure if I made a silly mistake on my end but I’m unsure as to how to fix this issue and have the build appear as it does on my game window. Does anyone have any suggestions on how I should proceed? I posted 4 photos (2 before build screenshots and 2 post-build screenshots) for reference. Thanks, everybody!

1 Like

I read a comment somewhere about this before, sorry don’t remember if it was on this forum or Unity Answers. As I recall, the issue you’re having is related to the WebGL build setting and the solution is to change the size of the build window in the output files.

That’s what I’m suspecting, too.

@Shahmario, go to File > Build Settings > Player Settings and make sure you set a playable resolution there. Secondly, design your game for that resolution.

Last but not least, check if you set the anchors correctly in the Inspector of your UI elements.

See also:


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms