Can't push from Source Tree to git

I get this error when trying to push from Source Tree to Git

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks push -v --tags --set-upstream github master:master
remote: Support for password authentication was removed on August 13, 2021. Please use a personal access token instead.

I have not been able to successfully proceed from this part in the course.
I’ve seen many, many posts about this question in several forums… but no real answers, is Git just simply broke?
The only answer I’ve seen is to not use Git and use GitKraken.
I’d really like to continue with the course, but I need help with this before I can continue.

Thanks for the link. It looks good, but doesn’t work when directions are followed.
I created the PAC as directed, posted into the git password in windows credentials manager, but still does not work. I get the same error.

Support for password authentication was removed on August 13, 2021. Please use a personal access token instead.

Surely someone knows how to correct this issue… or does no one use GitHub anymore? I see a lot of posts on this issue with no answers all over the web.

I got it to work… with SSH on Windows.

  1. Create SSH public and private key in SourceTree. (Under Tools > Create or Import SSH keys. Then click Generate button {move mouse around}. Add in key passphrase.) Leave that window open and go to Github.
  2. Then in Github, under account settings, in the SSH key section, add that public key generated from SourceTree by pasting the bunch of gibbish from that PuTTY Key Generator window into the text area when you add a new key. May want to make a copy of your private SourceTree key so that you can retrieve it readily. Because by default that SourceTree directory isn’t under program files… it’s in local user. :roll_eyes: Also jot down that passphrase.
  3. I needed to restarted SourceTree. That url which was for HTTPS won’t work. Will need to use the SSH url for Github repository. If the process prompts for keys… use the ones you saved earlier.
  4. Now try to PUSH the commit to Github. (Delete your earlier setup with SSH if it doesn’t work the first time. Maybe some settings still stick.)

It will be good if Ben amends his notes for PC users for this SSH method.

1 Like

WOW! Thank you so much! I can’t tell you how many tutorials and YouTube videos I’ve tried to figure that out. The SourceTree and GitHub information is so hard to understand, for noobs like me that is! I appreciate the time and effort you put into finding this solution for me. Now, I can continue with the course!
:grin: :pray:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.