Can't Move

In the section Local Rotation when Collision preset is set to BlockAllDynamic if the player pawn is touching ground i.e its capsule collider is touching ground it doesnt move

1 Like

Hi, I don’t know if you got it working already however I’ll answer for future students.

Your correct if the capsule is touching the ground you won’t be able to move, so your BaseMesh has to be just below the CapsuleCollider in BP_PawnTank. See below for how I set mine up, the wheels are just below the Capsule Collider.

*An unrelated tip I haven’t seen here. If you drag your PawnTank (or literally anything) into the Editor and its hovering above a surface/platform/object you can just hit the END button on your keyboard to snap it to sit on the surface. Pretty handy in a lot of cases. In this case, it makes the bottom of my CapsuleCollider sit on top of my surface.

The problem with the END key is that it makes the bottom of the capsule component level with the ground and with BlockAllDynamic enabled, it senses an overlap and your tank won’t move at all. And if the bottom of the capsule component is higher than the bottom of your wheels then the wheels will go into the ground. To get around this, your tank’s starting position must be floating a bit off the ground. I’m not sure how to get the tank moving if the wheels, capsule component, and ground are all aligned.

Here’s what I got:


If this is level with the ground, it won’t move.

Note that it doesn’t matter if the wheels are inside the ground or not. Only the root component is taken into account when doing a sweep. So in the case of this lesson, only the collider must not touch the ground.