Can't escape!

My player cannot leave the first tile! Tried resetting dimensions close to video, and still wouldn’t work!

@DanM my repo is

A video of the behaviour?

I’ll try to send one :relieved:
It is similar to before applying the gate toggling logic in the lecture, as if locking doesn’t work!
Tried disabling collision on the barrier/gate, but this allows bidirectional traversal, again as if locking never occurs.

Here’s a video of me bashing against the wall! :rofl:
@sampattuzzi got it as requested!

@DanM still open for business and this one’s a major snag I wanna get out of my way for going through the course.

Sorry I had hard drive woes earlier this week. Will look into it shortly

Now I know this has been happening frequently but I hit on silly mistakes more often than people. :roll_eyes:

So the bug was this: the box collision didn’t have a Z-location equivalent to the floor. No overlaps -> no execution flow. :expressionless:

So it works now. :disappointed_relieved:


Privacy & Terms