Can not drag and drop a unity package


I’am using for a while now Unity, different versions on 2 different Windows computers (10 and 11)
In the courses always you do a drag and drop of a unity package. but for me it is not working. I can see the arrow changing to a + indicator when dragging over the assets window, but when i release nothing happend. The rest is working ok when i double click the unitypackage to import it. So luckily no problems. But my question is now, do i mis something for the drag and drop method?

Kind regards,
Bert Berrevoets

Hi Bert,

Do you use two different versions of Unity to develop the same game project? Which versions of Unity do you use? Unitypackage files are not compatible with all versions.

Have you already tried to import the package via Assets > Import Package > Custom Package? See here:

1 Like

Yes, just what i say, everything is working ok, also the import of a custom package, also double clicking of the package is working. the only thing not working, is the drag and drop. For the tutorial i use the same version (2021.1.5f1). This is not a problem with certain versions. What i mean is i am using more versions on 2 different computers and with none of them it is working.


Do you use an antivirus program or a firewall that might be blocking Unity? Maybe the same antivirus program on both computers? Did you save your project on the Desktop or in another managed folder on your computers?

The projects i always create in D:\repos\ so no problem there. Even without a antivirus program, only Windows Defender, and with the firewall off, it is not working.

Maybe there is a bug in your version of Unity. Unity 2021.1.5 was released in April 2021, almost two years ago. Who knows if there is some incompatibility with Windows 10 (and its updates).

Have you already tried to install the latest version of 2021?

I have test it on different computers (on windows 10 and windows 11), with different versions of unity from 2019 to 2022, it is not working for me. Can it be a setting in Unity or in windows?

Unfortunately, I do not know either what the problem might be. It is odd that importing the assets does not seem to work on any of your devices. :confused:

Test something in Unity: Try to import an image (*.jpg or *.png) into Unity. If that works, import a sound clip. If that works too, there very likely is no problem in Unity.

Then download the assets from the course again. Make sure to unzip them if they are in a zip file. If you use a Mac, use “The Unarchiver” . If you see cryptic file names, your Mac extracted too many files from the zip.

And if that did not worm either but importing pngs worked, download the pngs (not the meta files) from our official git repository on GitLab. Here are the links:

It is very strange. When i install the exact version of unity as in the video. The drag and drop of the downloaded package is working, but not in unity 2022.
But when i create may own package from unity 2021 as used in the video, the drag and drop is working on both versions???

I think i stop looking for an answer for this, because everything else is working perfectly.
And by the way, i think your tutorials are great!!!


If you encounter the same problem again in the next section, please let me know, and I’ll take another look into this issue. If the same problem occurs in two different projects with different assets, it is often easier to find the reason. If it only happens in one project with one asset, the asset might be broken. I don’t know why, though, because it works for other people.

If you found an alternative solution, don’t worry about this problem anymore.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms