Camera behaving sporadically sort of

Hello people! For some reason my camera isn’t behaving properly and I’m almost sure I’ve configured things exactly how Ben did in the lecture. Even tried downloading his commit and overriding files, but the same thing happens.

So I’ll try to describe my issue as best as possible:

When I “Play” the game, upon trying to move/rotate the camera let’s say to the left - it goes both left, but up and down at the same time (very chaotically). Ok, so I tried to break the connection for the AimElevation node to see if only the rotation side of AimAzimuth is the cause. And so when I tried moving the camera to the right it goes relatively fine, but upon trying to move to the left it kinda gets stuck, as if something is blocking the path and I have to move the mouse like I’m steering a ship in order to force it to “overcome” this obstacle and continue moving to the left. And even so, I have to continuously move the mouse in order for the camera to overcome these “bumps”.

I have absolutely no idea why this is happening, so I hope someone here might lend a hand and enlighten me.

Here is a link to my GitHub repo:

Thank you in advance!

@DanM Sorry to bother you, but you seem to know your stuff, so I figured I should just try and catch your attention. :slight_smile:

Other than your inputs being incorrect (Elevation is on MouseX and Yaw is on MouseY) it seems to work fine.

Thank you very much for taking a look and for the fast reply! But aren’t my inputs like that? o.O

Here’s a video I just made showcasing the problem:

Yes, and I’m saying that’s incorrect. Looking left and right (azimuth) is set to the MouseY(up and down) and your up and down is set to MouseX(left and right). I’m saying that you need to switch that
Change your AimAzimuth to MouseX and AimElevation to MouseY

1 Like

Gosh do I feel silly… Thanks a lot and sorry for misunderstanding earlier! Greatly appreciated! :slight_smile:

Privacy & Terms