C++ extension can't open any header Unreal header files

My C++ extension can’t access any of the Unreal header files and by the looks of it Unreal cpp files can’t access them either, the program compiles just fine but it’s annoying as ****. I am using the VS compiler as I understand it should get all the paths it needs from there, I may be misunderstanding stuff.

What I tried:
-Reinstalling the extension
-Repairing the entire VS (I thought it was the compiler)
-Reloading files
-Restarting everything

My environment:
-VS Code (did the same in Visual Studio)
-The project and all installations are in D: drive (might be the cause of the problem?)
-Unreal 2.47

Images attached


Have you tried refreshing the source from the Unreal Editor. I believe there’s an option in the file menu. it sometimes helps.

Could you try my workaround described here?

Yes, sadly it didn’t help.

I can’t find said json, in the .vscode folder I only have an argv.json and an extensions folder. Am I in the wrong folder? This one is located in my user files.

It should be within your project folder e.g.

image

Thank you, Dan! This has fixed my issue. I hope I won’t have to add those 2 quotes every time I add a new object lol.

You probably will so you might what to check out this extension

https://gist.github.com/boocs/f63a4878156295b6e854cac68672f305

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.