Button not working

Heya, ive made an error somewhere, but i cant figure it out myself…
ive checked that ive spelled the code correctly in level.cs and checked that its hooked up to the button, and i have tried re adding the level.cs to Level gameobject…

gif showing no function
I hope you can tell me where i went wrong… because i have spent 15 mins now, looking and tinkering over it, but can’t figure it out… if you cant help me i have to remove all from this lecture, and start over.

EDIT: video of problem: https://youtu.be/BR_Pmkra0jc

1 Like

Is the scene included in the build settings

yeah its added. tried readding it there also :S

Can you throw in some debugs to verify it is getting called properly? Does the console have any output? Put a Debug on the button click event as well

what an awesome idea ! ill be remembering this one ! ill give it a shot after dinner !, then ill be back with the info ! :smiley:

i tried putting in the Debug.Log(""); but to no use. ive recorded a video clip of it hoping it can shed light on whats wrong…

The event system that is normally made with a canvas appears to be missing inside your hierarchy. Maybe this is causing the issue.


Thank you so much ! that was the problem ! you just saved me many hours of redoing the code, and i might have ended up with same error ! lots of coding love from me to you !

1 Like


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms