Build pending wont show in local server

My Hacker game has been pending for ages now and cant play it in the local host. This has happened before. Not sure what to do. I know the build is ok although there is no quit function but was not included in the lectures of that section.

Hi Louise,

Actually, your game should not be pending locally in your browser because you don’t depend on a working internet connection. The files are already there.

Are there any error messages in your browser when you try to run your game locally? A couple of months ago, a new security restriction was implemented in the major browsers.

I usually set privacy.file_unique_origin to false in the settings of Firefox to test my game locally, then set it back to true. See here. (You do not have to download anything.)

I dont have Firefox on my Mac which i use for Unity. Build is still pending since yesterday.

There is this error message in browser

That does not look like your local server but Maybe they are currently experiencing technical issues, which is not uncommon at the weekends when hundreds of people upload their games. Have you already tried to click on “Delete upload” and to try uploading your game again?

Maybe you could also try to clear the browser cache before you upload it again.

1 Like

ok will try clearing the cache. i will take game off after i tested it. just that i’m doing the 3d unity course as well as the 2d covering the basics. Like learning any skill or language involves repetition.

still no luck after clearing browser cache and re uploading

Did you test your game locally in your browser? If not, do that, please, so you can exclude that the problem is the project itself.

Do you have any script blockers installed?

If nothing helps, I’d suggest to upload your game onto

Script blockers ? Please explain. It wont play in local browser just get this.

went on ShareMyGame using my PC Laptop and its uploaded but got this message

Your game threw a warning: Looks like you are rendering without using requestAnimationFrame for the main loop. You should use 0 for the frame rate in emscripten_set_main_loop in order to use requestAnimationFrame, as that can greatly improve your frame rates!

SIMMER recommends fixing this and uploading again for better WebGL

Its working ok anyway and thankyou Nina

Just one thing. It’s working if i down load game from my PC Laptop but not from my IMac which i used Unity for.

All seems to be working fine now

Fantastic. What was your solution on your Mac?

I used Safari rather than directly from google Chrome. It was that simple really.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms