[Bug?] BP and class missing when reopening the project

First of all I’d like to point out that I’m following the course by taking notes and then trying things out by myself (i.e. not coding along, but trying to get to the same result and then checking the difference).So, having said that, let’s go.

I don’t know if this has been asked before, but I didn’t find any hint that it has. I’m facing a strange behavior in Unreal Engine: I’ve made the MovingPlatform class, went up to the point that in Tick the actor vertical location gets updated by the moving speed. So far so good. I’ve created a blueprint derived from the c++ class, placed in the level, and tested it out. It worked.


Whenever I reopen the project, I can’t see my “Public” folder with the C++ class, and the BP_MovingPlatform is missing from the Map and the outliner (with the Load Errors seen here).

Every time this happens, I have to reopen the VS Code project, trigger another Live Coding rebuild, and then I can finally see my class, but my Blueprint still doesn’t work properly and this message appears:

Blueprint could not be loaded because it derives from an invalid class. Check to make sure the parent class for this blueprint hasn’t been removed! Do you want to continue (it can crash the editor)?

Any Idea of why this is happening and how to fix it?


If I remember correctly, there was a lesson tackling this issue…
Its called “Live Coding Issues”.
What works for me is, to start the engine from within VS by building it with “Development Editor”

Unfortunately I’ve checked that lesson, it doesn’t tackle my specific problem. Anyway, I’ve managed to make it work by deleting all generated folders from the project root (i.e. DerivedDataCache, Intermediate, Binaries and Saved) and reopened the project. Both the class and the derived blueprint were visible, and my blueprint was visible in the level. I wonder which action caused the issue, and if this solution will be a definitive one.

I’ve been having the same issue as well. Every time I make a change to the header file of a BP C++ file, I need to delete those directories and rebuild them.

Yesterday was another terrible day. For some mysterious reasons, my Live Coding function completely stopped working. I kept having an error revolving around the file Livecoding.Json . “Missing LinkerPath field”, it spelled, but searching in the web for the whole afternoon didn’t give me any insight of why this happened and how to fix this. I couldn’t even compile a brand new c++ project. The only thing that fixed the issue was verifying the installation of the engine I was using. I wish Epic would give a little more info on these kind of issues…

For my particular issue, I realized I was using the wrong build task. When I started building with Editor Win64 Development build task, it seemed to fix my issues. Just to be safe now, every time I make changes to a header file I close the editor and compile with the Editor Win64 Developer and I haven’t hit any issues since. Give that a try and see if that fixes things.
I also periodically rebuild my VSCode project through the editor with Tools → Refresh Visual Studio Code Project.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms