Broken aiming when looking at high objects


So the aiming actually is working, but if your camera is swung round to view from low down to high in the sky, then the aiming won’t work.

From what I can tell this is happening when the camera is below the level of the floor (even with FMath::Abs).

You can change the collision settings on the landscape, and then I have been able to do to aim around me from below the floor, but that means that I can no longer aim at the landscape itself at all!

Possibly you could have different collision for different sides of the landscape?

Any thoughts on fixes are welcome :slight_smile:

Clamp your camera so it can’t go below the ground?

Ahh but then I still can’t aim at high objects in the world.

What if, for example, I wanted to fight heliocopters or put bunkers to destroy high up on the mountainsides. Clamping the camera would prevent that

Do you not have the spring arm setup correctly? it should compress inward if there is something blocking the camera, like a spring.

Ooo, that looks like a promising suggestion.

I can’t be sure it’s correct! It was my first time setting it up. Here is how my springarm looks:

The probe size is the only way I can tell to lengthen or shorten the spring arm?

I had probe size only on 12 when I started, and increasing or decreasing the value doesnt really help. Changing the probe size does clunkily move the camera a bit closer to the tank, but not enough to avoid clipping the camera through the landscape.

Perhaps I have missed something though?

Ah! Figured it out. Thanks for the tip on that springarm Dan, it was what was fouling it up. The camera had its own distance set from the spring arm, which is what was making it poorly manipulated.

Here is how it is now:

Yeah that’s looking correct now :slight_smile:

thanks for the help as always!

Well I was having the same issue, thought it would be tackled in the future lectures!
Will correct it now.

Privacy & Terms