Bridge Edge Loop messed up

I’m currently working on the low poly chess set and trying to use the “bridge edge loop” function to attach the little ball to the top of the bishop. Unfortunately there seems to be a bit of a mess when I do that and somehow the newly created edges are going to very unexpected places. I attached two screenshots below before and after I used the bridge function.


I activated normal coloring so the problem is easier to see. I would expect here that the connection that is created would try to connect the vertices that are closest together, but somehow it is doing the exact opposite. I already tried the options in the configuration panel, but somehow none of them seems to have any effect on this issue.

Is there maybe an issue with the underlying mesh that im not seeing here? When I tried the bridge funtion in a new blend file it worked fine for me.

First, be sure to select the same amount of vertices for both loops.

Then if this happens maybe you can try the Twist value under the options (you can see it in your second screenshot)

The vertices are the same for both loops. And I also tried using the twist value, but that didn’t do anything for me, just made it look differently screwed up. I even tried bridging the loops and then rotating just the top part, but that also didn’t do anything to fix the issue :frowning:

Must be some extra vertices on top of each other then…
Try alt+m merge by distance before the bridge.

Anyway I see you succeeded in another file, so you can just append the object from another file to this one. :smile:

Unfortunately it also wasn’t a problem with multiple vertices overlying. To fix it I just created the faces manually in the end by selecting the adjacent edges on both sides one at a time. A bit more time consuming, but the end result now works fine :slight_smile:

@dadriel unfortunately I’ve seen this a few times and there can be various reasons, from distances rotations etc…

But, if there are the same amount of edges on each loop, to bridge them a bit quicker when the straight forward select all doesnt work and you get that strange inversion, what you can do is select both edge loops as you would do normally. then deselect an edge from the top one, and deselect its corresponding edge on the lower loop, then try the bridge edge loops.

this would only leave you one face to manually connect up. Bit of a pain, but its one of those little annoyances. still, if you have a massive loop to create, only one to manually add, is still a time saver.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms