Bricks are still smooth after following tutorial

Hi there,

I’ve been following the lectures for Blender Material Nodes Mastery: Create Spectacular Textures and am up to Procedural Brick - Random Brick Shape. In the video, the Viewport Shading is switched to solid mode then back to cycles. Here is a screenshot of the result taken from the video:

When I tried to do it on mine, nothing changed. I downloaded the .blend file from the lecture and had the same result:

I had a similar issue with the Sand Sculpture Shader, and it turned out that the issue was the different versions of Blender. So I downloaded version 3.5.1 (same as the lecture) and still had the same result. Then I downloaded version 4.0.2 and still had the same issue.

I’m not sure what else could be the problem. Would appreciate any help.



Have you got the same resolution and subdivisions on?

Yours just looks better more refined. Course one is just showing unsmoothable topology, may be a lower grade computer set up.


It could be a number of different issues, however, I’d really need to see the node tree to try and figure out what the issue is. As a guess, I’d say it could be either the scale of the noise used to distort the brick shape, the way its blended or added to the node tree or perhaps something to do with the amount of subdivisions.


Thanks both for your responses.

I’m trying to post the node tree via some screenshots. Unfortunately was not able to upload the .blend file itself. Please see attached.


When you go into camera view and render the image how does it look? I can’t get it to look right in the viewport either, but when I render the image, it looks correct.

If rendering with Cycles set as renderer, and in rendered view, to get the best match to the full render make sure Scene World and Scene lights are ticked.

There may still be a difference in the subdivisions used though, the modifier has a setting one used for the viewport render the other for the full render.

1 Like

Hi there, the bricks look the same in the viewport as in both camera and rendered view. I have scene lights and scene world both checked. Any ideas about what could be causing this problem?

Looking at the node tree, I don’t see anything that jumps out as being too far removed from my own. What I would say, once you have all the layers of noise, cracks, chips, the final colours, maybe roughness, dirt etc, the lack of really high frequency noise around the edge won’t really make a huge difference.
Perhaps as you go through the next few video something will click and you’ll figure out the issue with this one part of the displacement map.

Privacy & Terms