Bone number 003 not visible in some view modes

One of the bones in my armature does not appears on Object mode or in Pose Mode. it is not hidden.
any suggestions?
Thanks.

1 Like

The individual bone can be hidden, in Pose mode, bone properties, viewport display.

That would match being visible still in edit mode.

1 Like

Perhaps you’ve moved it to a different bone layer.

To check that, click on the running man icon in the properties panel and navigate to Skeleton tab usually at the top and find the layers.

image

You can press Shift and click on any bone layers (Under “Layers”, NOT “Protected Layers”) where there’s a white circle (this indicates that there is a bone in this layer).

image

Once all are active, you might find that it’s once again visible.

Hope that helps and perhaps solves your issue?

1 Like

Thank you guys for your answers. Sorry took me time to answer but I can’t practice every day.
I try both but options but is not any of them.


There is a dotted line where the bone is suppose to be.

Have you added a custom bone shape to the bone? What’s that cone shape in pose mode? Is that the boe with a custom bone shape?

Hi Mark. Thanks for keeping track. I thought about it and it was close. Because the custom object I asingned was to the control bone “bone 04” which I renamed “control look” but checking bone 03 in pose mode, in viewport display> custom shape> custom object it was selected “Camera” :flushed: which I do not remember making such selection (Yellow circle) , but could have happened with all that clicking about.

Once I unselected camera (Red circle) the bone 03 appeared again.


Thank you for the help Mark, Your direction to the problem helped me to find the solution.

1 Like

What a weird cause!

Well done finding it.

Often the way, easier to delete and remake than find such problems!

Thank you too NP5 :+1:

Ah ok, this is a bug. I hadn’t seen it for a while so I thought it had been solved but looks like it’s still about. The camera object can often be swapped in as a custom object and sometime meshes can be selected as the active camera. This bug’s been around for a while.

Glad you were able to find the solution anyway.