Blueprint Function "Get Attach Location" crashes game

The function in the video “Get Attach Location” will crash the game on play when utilized. The cause is unknown and I have narrowed it down to this function since I can spawn this blueprint when incrementing the new transform manually myself.

^ On the left is the function from the video; On the right is my temporary workaround where the function would normally be accessed and cause a crash.

getting the arrow transform without the function also crashes.

^frozen unreal editor after hitting play

turns out getting this transform anywhere crashes it. I tried doing it on the begin play of the blueprint actor itself, with yet another crash.

Actually it doesnt crash it until this variable is accessed from the gamemode

Changing to a vector didn’t crash, but I get this odd result instead :frowning:

Even though the Z location should not be changing.

It is not a problem with actors overlapping.

And thus I am back to another sloppy fix :confused:

Edit: Nevermind it was because the arrow component wasn’t at location 0.0 on Z. Due to the big walls making me offset its location prior.

This isn’t a REAL solution, but it has to do with fetching the actor components transform from outside the actor. If you fetch the location vector separately, it will work. Havn’t tried fetching rotation and scale manually yet though.

Privacy & Terms