Blender doesn't render animations

Hello everybody,
I fixed the lamps movement, but now Blender just won’t render anything, neither in Cycles, nor in Eevee, nor in Workbench.
That is all I get:

However, the Rendered view mode works (Render settings included)

Output properties:

Where shall I look and what may have gone wrong?
I tried to relaunch Blender, checked file path and CPU/GPU, everything looks fine.

UPD: It seems that there are some issues with animated files. Static projects are rendered successfully, but the animations don’t (including the one I posted here earlier).

I encountered this problem too in Eevee, just a single frame. No animation.
I think it is a memory problem. Too much to do for blender.
And probably bad Blender project configuration.

With the last comment, I mean; When learning Blender you try out a lot and everything seems to work. But not all Blender configurations lead to optimal Blender models, textures and material design. Because of unlogical blender configurations. Blender gets confused, needs a lot of memory …

When I got into a situation where I am going to experiment with some features. I save under a new file name. In that case, my original project doesn’t get polluted with forgotten options, model tweaks, hidden hotkey commands, etc.

Try to remember what you did the last, before blender freezes. Clean up, simplify.

1 Like

The problem is that I saved it under a new name, though even my old .blend file that I sucessfully rendered for 42_pl_cbc doesn’t work as well (IIRC I made no changes there to keep it as a definitely working copy). And I can’t even render a single image: image renderer shows me a blank window.

I tried to experiment and even switched both lamps off but it still results in a blank window - even if I try to render a simple image. Moreover, the Blender crashes if I set Eevee render device to CPU and try to switch to the rendered view.

I think you’re right, and there’s some problem with Blender settings… But why does it render my older files, and why doesn’t it process a file that actually worked? I’m puzzled.

1 Like

If you’re comfortable with it, share your .blend file. I’ll take a look and see if I can find anything amiss.

Nevermind. I looked through the lections and found out that I forgot one small thing I made both to my working and to the recent copy.

Aaaand it’s what Mikey warned about. But I deleted my souce .png’s, and thus it couldn’t render anything.
Thank you everyone and sorry for the false alarm:)


Glad you solved it on your own.
This means you are getting more confident and able to rethinks about the steps you did.


Yes, always feels good to figure out the issue, what caused it and how to solve it.
I am glad you got it sorted too.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms