Behavior Tree inactive

Hey guys I am at lecture 205. My behavior tree says it’s inactive whenever I hit the play button even though I followed exactly and re checked it again. It seems like I am not able to solve this problem. I am using UE 4.14.3. Please help me. Below I have attached the screenshot. Thanks.

The only thing that worked for me was creating the graph shown in the Unreal docs: 6. Setup the AI Controller Blueprint.

Not sure why exactly but hope this helps.

I have the same problem in 4.18.2. All I had to do was add the Selector Composite and Move to Task under the Root to wake it up. :smiley:

1 Like

Just to clarify for other people, it seems that in later versions of unreal, the engine won’t bother to simulate an empty behaviour tree. If you arbitrarily add some nodes below (e.g., in the Patrol behaviour tree, from ROOT, you can add Selector and Tasks–>Move To), it will start simulating it. Then you can confirm it is indeed working.

In other words, just finish watching the video. It should clear up the issue.

1 Like

That advice worked for me as well :slight_smile: Just watch for the end of the video, we will add a Key to a blackboard, and everything will work properly.

Unreal version: 5.3

In my case, I had dublicated BP_AIController file in the Content folder and in the newly created AI folder. I did moved the file from the Content folder to the AI folder but for some reason unknown, this file was duplicated.
After deleting one of them in the Content folder, everything worked.
Of course the file assigned to BP_ShooterCharacter’s AI Cotroller Class shall be the BP_AIController located the AI folder.

Privacy & Terms