Argon Assault problem

I have a problem that I can’t figure out, when starting my game the ship moves really fast for the first few seconds then slows to its proper speed. I have tried placing it in various locations i:e at the start of the circuit, at the end of the circuit but no matter where i put it, it does the same. Has anyone else encountered this problem and if so how did you solve it. Here is a short video showing the issue.

Hi Anthony,

Have a look at this topic;

1 Like

Hi Rob, I’ve seen the topic but being a beginner it means nothing to me as it’s not very clear what to do, very frustrating as I die instantly as soon as I start the game due to the shear speed its moving and I can’t progress untill i’ve resolved this issue.

1 Like

Anthony, (and others in the same boat)

For now, you should be able to set (in the inspector, see screenshots below, if needed) the lookAheadForTargetOffset variable and get some control over your flight speed… I expect it will still be jerky, but it should get you by until the lessons where we replace that with timeline functionality. [Note: I never tried any circuits with more than 10 waypoints, it’s conceivable my workaround doesn’t work if you have too many waypoints, but otherwise I expect it to help]. I found values close to one (0.8 - 1.2) working best on my circuit.


1 Like

Thanks for the info JackDraak, I only have 7 waypoints so I don’t think that’s the issue, I also already have that set to 1, I’ve lifted the circuit way above the obstacles so I can finish the game for now, then i’ll replace later with the timeline feature when the lessons are updated, cheers for the help though. I might have a tinker around myself and see if I can figure out a better way of doing it, I have a couple of AI pathfinding assets I purchased some time ago that i might try out, ya never know it may give the correct affect i need.

1 Like

Privacy & Terms