AI not moving past second target point

Hello all,

So my enemy moves through the first target point and onto the second, but just stops and plays the idle animation I’ve set up at the second. I’ve tried using a different target point for the second one and the same thing happens. I’ve tried using a print string on success and fail at the second one, and they don’t fire. I’ll attach screenshots and move on as I’ve been stuck here for days, but I’ll keep coming back in hopes someone answers this. Thanks!



Just to clarify, does the AI Character reach the second point (and stops trying to move to the third) or does it only reach the first?

A quick thing to try is to lower your target points so that they’re closer to the floor.

YES!!! Moving them all the way down to the floor (by pushing the “end” key for any future new devs reading this that may not know) fixed the issue! There is still a problem with clipping but I’m not too worried about that for the moment. He at least moves where he’s supposed to now. Thank you so much!

Privacy & Terms