Adding the repository question

When I try to add the repository in sourcetree it asks for a repository type. It’s not like in the video where you can pick git or the other one. It’s asking for a path.

So what exactly do I put there?

Can you put a screen shot of what you see? When I check on my SourceTree, I can choose a repo type and then a directory.
I also just downloaded the lates version of Sourcetree. I saw somewhere there were a security risk with some version.

That’s for adding an existing repo to sourcetree, you want to be on the create tab to create a repo

Ok now it’s saying the repos folder i created already exist and is not empty but I don’t see another repos in my documents folder. The folder I created is empty.

  • Open the terminal from the top right
  • Navigate to the folder using the cd command cd "C:/path/to/folder"
  • Use git init to initialise the repo.

Tried that and got a " ‘git’ is not recognized as an internal or external command,
operable program or batch file" error.

Sounds like you don’t have git installed. In sourcetree go to Tools > Options > Git. And at the bottom there should be use system git or embedded git.
Not sure what that looks like if you don’t have the embedded git installed but hopefully it says something obvious like install embedded git

Got it to work. I deleted the repos folder and then set the destination to go to where the repos folder would be if it were there.

I’m having the same issue where SourceTree tells me that the folder already exists.
So we are no longer allowed to create new repositories in existing folders?
This makes no sense to me what so ever.
So if I have already created an Unreal project, I can’t later just add it to a repository?
That’s crazy

It has something to do with this option:

With the option selected, I get an error.
Without it, I only get a warning that allows me to continue:

Do you think this is a bug on their end or is it supposed to work like this now?

1 Like

The same thing happened to me, I ended up leaving it unchecked.

1 Like

What I did was create the repo on github then I just cloned it into a folder and it worked perfectly fine.
Also I made sure to create the unity project in the folder that I cloned the repo into.

Thanks for this, was having the same problem and appreciate the info

Privacy & Terms