About 'Set Up Project'!

In this video (objectives)…

  1. Create new Unity project.
  2. Download art assets and import them.
  3. Set up background, player, enemy, camera and aspect ratio to find something we are happy with.

After watching (learning outcomes)… Create our project and be happy with the aspect ratio, sizes and proportions.

(Unique Video Reference: 3_LD_CUD)

We would love to know…

  • What you found good about this lecture?
  • What we could do better?

Remember that you can reply to this topic, or create a new topic. The easiest way to create a new topic is to follow the link in Resources. That way the topic will…

  • Be in the correct forum (for the course).
  • Be in the right sub-forum (for the section)
  • Have the correct lecture tag.

Enjoy your stay in our thriving community!

The Low Resolution Aspect Ratio is not active, and it seems is only active on retina display.



Hmm, thats interesting. I’m not on a retina display and I have the ability to toggle it on and off.

Same thing here, I’m using a PC, Unity 2018.2.3f1 and the box is ticked but greyed out so cannot be changed.

This feature was added some time ago, introduced in Unity 5.5 I believe. It only appeared in the editor if you were running Mac OS, this is stated in the 2018.1 documentation and prior, all the way back to 5.5. However, since 2018.2 it has been displayed on all platforms, but appears disabled on non-Mac OS.

It could be a regression issue, as if you look at Unity’s Issue Tracker there are a number of issues relating to this feature and a few of them are marked regression, additionally, there is no mention of this being added as a feature in any of the release history from 2018 onwards.

This is from the bottom of the 2018.2 documentation;

Guess you may need either a Mac, or just have a retina display in order for this option to not be on and disabled by default.

@Rick_Davidson, are you perhaps running Unity on a Mac, hence having the choice to disable it?

1 Like

I wouldn’t dream of using a mac! :slight_smile:

Nope, I’m on windows 10, Unity 2018.2. Ill make an edit to tidy this up.

It could be that although I use 1080 when recording the videos, my laptop is 4k and therefore Unity thinks I need this option.

1 Like

Hmmm… so you can check/un-check that item Rick?

Ahhh… 4k… that must be it then…

Yep, I can check / un check it.

1 Like

Gotta be your awesome 4k laptop then… I also don’t have the ability to un-check it, but then I am scratching into a wax tablet with a stick… it’s quite amazing I get anything done at all…


I am also having the issue of it being greyed out.

While searching the net for some answers I found basically what the consensus here seems to be. Any retina display, or mac will enable the option. I also found out that any sort of scaling of your Windows UI will enable the option as well such as increasing text or icon sizes.

This leads me to believe the 4k monitor is likely the culprit.


Privacy & Terms