About FBX exporting for Unreal Engine and loosing sharp edges

Hello all,

I’ve completed my model and prepared it for export to Unity and Unreal Engine
making it become a single mesh with vertex groups named the same of the bones.
No problem at all with the armature and no problem in Unity, but in UE I lost the sharp edges that I had obtained in blender using the edge split modifier (thus doubling the vertices).

These are my export settings for the FBX format


I searched a bit on the internet but none of the solutions listed worked
Has anyone else had the same problem and found a solution?

Blender kart - one mesh and no doubles removed:

Unity kart - sharp edges present:

Unreal Engine kart - horrible edges:

That’s exactly the type of thing that led me to drop Unreal and go back to using Unity. I doesn’t matter how good the features are if you can’t get your meshes into the program.


After further investigation I found a solution to this problem by myself.
The process I describe here is destructive for the mesh in Blender, so save the file with a new name before proceeding…

  1. Select the object, go in edit mode (tab) and select all (A)
  2. Click “Remove doubles” in the Tools — After this the smooth will be ruined in Blender view —
  3. deselect all (A)
  4. Go to “Select” menu > “Sharp Edges”
  5. Go to “Mesh” menu > “Edges” > “Mark Sharp”
  6. Exit edit mode (tab) then export to FBX with this “Geometry” settings:


Et voila! :wink:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms