Very weird static tank behaviour

I was just following along with the making a main menu part of the course…

So, earlier I had setup a level, I spawn my own tank and there is also a “static” tank (i.e. no AI or anything).
Now, if I Play in editor with the BattleGround level loaded… nothing happens (well, the “enemy” tank falls maybe 20 cm or something, but thats fine) but… when I use the Start button (having a open level node attached)… this happens…

The tank… flies! Its a 40 metric ton (yes… I double checked that figure) tank… and it just gets thrown into the air…

Its pretty awesome to look at. I have absolutely no idea whats happening but… Well I just wanted to share this little tidbit with you guys. I’ll post here if I ever do find a solution :slight_smile:

So far, I’ve tried raising the tank further up. I thought maybe the tank was spawned before the landscape was fully ready, I figured maybe the tank falls into the ground and the landscape was loaded while the tank was in the collision box of the ground. However… this resulted in a sideways falling tank… I have no idea why thats happening… but its pretty funny :smiley:

I had the same issue, and while it may or may not work, try deleting it off the level. Then going back into the tank folder and dragging the Tank_BP file back on to the level.


I tried it a couple times but not much luck. Next i figured I’d try Bens version, so I cloned the repo (Checking out the BT27 commit), build it against my engine version and tried it. The tanks he has have the exact same problem. (even on his own levels)

My guess is it might be a bug in the engine version I’m using (4.14.0-preview3). I’ll try 4.13 & 4.14.0-release over the weekend.

It was addressed in later videos. It was the collision meshes of the tracks interacting with the collision mesh on the tank body causing a race condition.

Privacy & Terms