Unreal 4.24 HDR warning

For some reason I get this repeating warning in the console even though I don’t have a HDR monitor:

LogD3D11RHI: Warning: NvAPI_Disp_HdrColorControl returned NVAPI_NOT_SUPPORTED (ffffff98)

What GPU do you have?

GTX 980 ti

What OS are you using? Are you using the latest drivers?

I guess you could just ignore it :man_shrugging:, seems strange to be getting it though.

NVAPI_NOT_SUPPORTED = -104, //!< Requested feature is not supported in the selected GPU

You need not concern yourself unless of course you want HDR then see DanM’s comment probably.

I looked it up as I’m building UE4 source to diagnose an OS issue so there you go.

Looking around on both Unreal forums this can also happen if your monitor doesn’t support the HDR features. So sounds like this is what you are running into.

https://answers.unrealengine.com/questions/847264/nvapi-warning.html

Doesn’t seem to be a way to suppress specific messages in the output log. But in the output log window, in the top left you can tell it not to show you Warnings or you can select Categories and disable the one called “LogD3D11RHI”