Too much Noise when using the Glass Shader

Why is there too much noise when I used the Glass Shader? Any idea how to fix this?

1 Like

Hi Vondodo,

You mean glossy shader right? Or is your surface using glass (maybe not?) By the looks of the screenshot you are using a glossy shader on the lamp but the noise is (mostly) on the ground where light is reflected, correct?

There’s something you can at least try:

  1. Play with overall scene lighting. If you have more light (unless you really need a dark scene) you can reduce noise in general. Darker scenes are harder usually to work with (at least for me)
  2. How is your actual light source set up in the lamp shade? Are you using a spot light and / or emissive material, or maybe both? Try to play with the sizes of the light sources and strengths. If you have both then use the spot light to be your main light and emissive material only so that if the “light” is visible in the render you actually have something inside the shade. Since the lamp (source) itself is not visible in the render you need geometry to act as your lightbulb or something similar.
  3. If your emissive material is the cause of this (you know it if you set the render visibility on the outliner to be none) you can try to clamp the indirect lighting. This is done in the render section under sampling. Under settings there’s a value called: Clamp indirect which is 0 if you haven’t touched it. This means brighter pixels of that value will be clamped. So you might want to try pretty high and work down to see where you get better results (if any).
  4. Cranking up your samples in the rendering is of course the last and easiest way to go but do not always help.

I created a dark scene where my emissive light is really bright and causes fireflies (bright pixels) like so:

And this is the same scene with indirect clamping (of value 2.0):

This is only 128 samples so you can really see the difference, if I crank up my sampling to 512 the bright pixels are not that bright any more so sampling can also help.

Hope this helps you forward!

Cheers, Jax

5 Likes

I was having this exact problem!

Awesome explanation of possible solutions, my render ended up looking SO much better after I applied that indirect clamping of 2.0.

Thanks again! :thumbsup:

2 Likes

Privacy & Terms