[Solved] Trouble copying and pasting

Hi,
Goal: I am trying to copy and paste both my ‘start’ button and my LevelManager script from scene Start to scene Game.
Expected: I have tried using both keyboard shortcuts (cmnd+c, cmnd+v) and the edit menu (edit–>copy, edit–>paste) to do this;
Observed: however, the paste option is grayed out when I try to past in my game scene. Furthermore, my LevelManager script appears automatically in my Assets pane while in my game scene. When I try to place my LevelManager script in the OnClick() trigger in the Game scene, I cannot select the script function or name the scene to return to normally and when I press play and click the button nothing happens, not even in the console.
Attempts to solve: I have tried to drag the LevelManager script to hierarchy panel, I have tried to create a new LevelManager script and drag into hierarchy pane, I have tried to use the current levelManager script and just selected monoscript.name from the drop down options.
I am using unity version 5.3.5f1 and am on a Mac.
Screenshot attaached depicts strange option of onClick() trigger, and asset and hierarchy panels.

1 Like

You copy/paste from the hierarchy (not the scene window) in scene 1 to the hierarchy in scene 2.

Yep, that’s normal. The assets are global across your game, not scene-specific. They become scene-specific (instantiated) when dragged into that scene’s hierarchy.

That won’t work. You need to add the script as a component of a gameobject in the Inspector.

Hope that helps a bit, you might want to revisit the early lessons on getting familiar with the editor.

1 Like