[SOLVED] Mouse is refusing to move

Version : Unity 5.5

Everything was going smoothly until this point but now the mouse is just not moving no matter what i do, not only
the movement to play but it isnt even showing the axis in the console box.
Here is the code :


Note : I changed it to 0.2f because it is different in mine but then i thought maybe that could cause the error so i changed it to to 0.5f but nothing worked.
Really need a reply, as soon as possible because im kind of stuck with this from 2 days.

Hello @soumith_potturi,

Try checking the name of your class vs the name of your file - See if changing line 4 from:

public class Paddle : MonoBehaviour

to

public class paddle : MonoBehaviour

will work.

If you want to keep the Paddle class as uppercase, rename script file itself in your assets folder, and see if that works.

I think the problem may be your class and filename aren’t matching (see below), which stops Unity from using the script entirely.
You should check you can even print()/Debug.Log() in Start()/Update().

Haha its not a problem. I figured that out like 10 years ago :stuck_out_tongue:
Thank you, anyway !

Privacy & Terms