[Solved] Buttons not working in scenes other than Start (Unity 4.6)

Observed: When I copy the Canvas (including buttons) by following the steps outlined at timestamp 6:40 into the Game scene, the buttons themselves are no longer responsive. They do not react to highlight or onpress.

Expected: The buttons from within the copied elements should react to highlight and onpress, just as they do in the Start scene.

Steps to Reproduce: Followed steps outlined at timestamp 6:40.

  1. Copied the Canvas (including buttons)
  2. Opened Game scene
  3. Pasted Canvas
  4. Played scene
  5. Buttons were not interactable

Steps I’ve tried:

  • I’ve attempted this with the Lose and Win scenes, the buttons are still not interactable.
  • I created a new Text UI with Button component within the Canvas in the Game scene, and it was not interactable. I copied and pasted this new Text Button back into the Start scene, and it then started working again.
  • I restarted Unity and the behavior did not change.

Solved: Never mind, forgot to also copy over EventSystem