[SOLVED]Animation Disappeared


My animation for my spaceships disappeared when I opened my project in Unity 5. I see some stuff in the animation window that looks new - An Entry box and an Exit box. Is that what is disrupting the animation cycle? The animation still appears to be in my folders but it just doesn’t run in the game anymore.

[SOLUTION] - I found another post that shows that you have to select the animation and then deselect Apply Root Motion in the Inspector window. Works fine now.

2 Likes

I was just finishing this section of the tutorial and realized the same thing. It happened to me and it also happens in the tutorial. Thank you Mike, for the solution. It works now (Y)
(Consider this a gamedev version of a fb like :stuck_out_tongue: )

for the authors: maybe a little update in the video itself so the future students can fix it right away?

I have this issue but I cant see “Apply Root Motion”
What else can cause this please.

Thank you

Its ok, I worked it out.
If anyone else need to know…
Select the enemy prefab then go into the inspector,
there you will find “Apply Root Motion” most likely down the bottom, uncheck the box and save.
Try your game now :slight_smile:

1 Like

No :frowning: not working.
It will play the animation but then they disappear.
And when I do a web build I have no score and the enemies stop respawning after a while

Privacy & Terms