Questions about the rpg course

what will break if i use 2.19.4.14 as opposed to 2.18.3.14 also can i use visual studio as opposed to visual studio code.

asking those questions because I’m using 2.19.4 as my unity version and visual studio as the editor.
I can’t look at the white screen all the time that’s one reason i use 2.19.4.14 as well as other udemy courses

We have found no significant issues with any version so far.
There can be issues when upgrading the project from one version to another (mostly losing references to animations and broken AnimatorOverrides), but these are just a matter of reconnection. If you start in 2019.4.14, you should be fine.

I use Visual Studio Community as my editor with no issues whatsoever.