Play in Editor seems to capture the mouse, always

Has anyone else noticed that their Unreal Editor always captures the mouse when you use “Play in Editor”, requiring a “Shift +F1” press to release it?

I found a preference called “Game gets Mouse Control” under “Editor Preferences” -> “Level Editor” -> “Play” -> “Play in Editor” but it appears to do nothing or be broken - whether it is ticked or not, the mouse is still captured when I press the play-in-editor button.

Perhaps someone has found a fix for this?