No intellisense on Monodevelop for Mac

Hi, I am just starting the Learn to code by making games course, and I am noticing that I do not have intellisense in mono develop on my mac. I installed version 4.7.2 in accordance with the course. Can anyone help me out?

Hi @Erik_Yedwab, how strange. Could you post up one of your scripts (the entire script) where this is happening please.

Rob, sure, I can, but this is happening on every single script. When I follow the instructions in the video, no matter what I do, I get no intellisense. So I suspect it is a setting or configuration issue. I did some searching, and nothing I find seems to help.

I had a quick search too, the reason I asked about the script was because in one comment on a similar issue they had mentioned checking that you had the Unity namespace etc at the top of the script.

In addition to that I found another which suggested that under the Preferences and General Settings that the IDE was set correctly, in one users case they were trying to launch a previous version of Mono which wasn’t installed, it was pointing to .net 4.5 I believe.

Then there were lots of posts around clearing various files and temp/cache files too - which seemed a bit full on…

I’ve only had a quick look so far.


It wasn’t this article, but I think this article points to the previous one regarding the Mono version…

I’d also recommend moving to Visual Studio if/when you can, it has a ran of features which Mono doesn’t currently have and it may resolve this issue at the same time :slight_smile:

Rob, thanks for your help. I am playing with it more and I think I am actually mistaken. I am now actually getting intenillisense, BUT, I am nog able to access the Unity DLL’s. For example, when I use Input, I am not getting any auto completion, and when I hover over Input.GetKeyDown(…) I get, the name input does not exist in the current context. However, I can save the script and it runs completely fine in Unity.

One other interesting thing, my solution explorer is completely blank. When I look at the videos, there is a solution in there. I have opened the scripts the same way as the video, and the script loads fine, and works fine in Unity, but just not accessing the Unity dll. I just hovered over using UnityEngine, and I got, UnityEngine does not exist in the current context. But works totally fine in Unity… Very frustrating.

Only thing I can think of is I previously had installed Unity 5.x on my machine, before installing this 4.7.2, and I THINK Unity just installed itself over the newer version, but the way Unity installs is weird, its not in my app folder.

I am on a Mac.

wouldnt have anything to with the project not syncing, I dont have a mac, but happy to have a look around tinterweb to try and search,

I’m not on a Mac either, I do seem to remember not seeing a solution in Mono when I used it though, I don’t typically see one in Visual Studio either, although there is an option for the external editor to create the solution file etc, maybe that’s what that needs. I do get access to the auto complete for Unity, but again that’s in Visual Studio so not the fairest of tests perhaps.

Just found this, not sure if it helps…

There is no auto-completion for UnityScript/Boo in MonoDevelop 5.9. You can still use MonoDevelop 4.0.1 for this. We recommend that users switch to C# for Unity development.

This was from the MonoDevelop Roadmap (check comments at the bottom, second comment, December 13, 2015) and a separate forum post (response from a chap at Unity)

1 Like

Hey @Erik_Yedwab - can this topic be marked as solved now?

Hey Rob, not sure if its solved or not. I was never able to get it working. I installed Unity 5.4 and it seems to work, but not sure if I can use 5.4 with the class. I am going to try to get back to it this week. If everyone wants me to change to solved, I will.

Hi @Erik_Yedwab, no it’s ok, it doesn’t need to be changed. I just did a search the other evening to see what was still outstanding from people needing some help. The posts don’t always get marked as [Solved] after they have been which was why I was asking :slight_smile:

Regarding the issue, I wonder whether maybe removing both of the two installed versions and then reinstalling them, but to specific directories, e.g. “Unity_4.7.2” and “Unity_5.x.x” etc - not sure whether it would resolve the issue but it might, sounds like something has gone a bit odd doesn’t it.


I just read in another post that you can’t specify the install path on a Mac. If this is the case, after you’ve installed whichever version first you’ll need to rename the directory before installing the second version. This may be why you’ve had some issues if one has over-written, or perhaps partially over-written the previous version?

Privacy & Terms