My courgette rotates awkwardly

Its movement isn’t fluid, it stops at the end of the animation before resuming.

nyone else with the issue?

I have no idea what you are talking about, but would still like to nominate you for a GameDev.tv Award in the category “Best Thread Title”. I sincerely hope the award comes with the answer you are looking for.

3 Likes

Its Indeed a funny title hahaha. @ZoidbergForPresident send a PIC of the animation timeline?

Lol, yeah I guess, and I haven’t done it on purpose. :stuck_out_tongue:

For the issue, it’s like the courgette is rotating once then waiting for a couple of frames before rotating again, and the animation seems correct, I don’t have the issue with the axe.

Which version of Unity are you using?

2017.1

Two things to perhaps look for;

  • As Johnny (@Joao_Dalvi) above suggested with the timeline, if you zoom out (mouse wheel down), you can check that there aren’t any extra keyframes on the end which perhaps you couldn’t see in the default view.

  • If the above doesn’t resolve the issue, try checking the first and last keyframes. Right-click on them, respectively, and check that Auto is selected, rather than Clamped Auto.

    image

Hope this helps :slight_smile:

2 Likes

There’s no frames for the courgette: it’s only rotating.

But changing to auto for the first and last rotation fixes it, what does that one mean?

In any case, thanks a lot! :slight_smile:

My courgette is now rotating perfectly! :wink:

3 Likes

Glad to hear that’s resolved it.

Clamped Auto and Auto are tangent modes, used by the curves for the animation. Auto is actually legacy now. There is some good coverage of these on the page linked below :slight_smile:


See also;

1 Like

I’ve found how to display the curve and I get why the rresult is like that. WHich one do I have to use to have a straight line? Apart from the legacy Auto?

1 Like

Auto was the default in the older versions of Unity, in which the animation did work without issue.

Looking at the copy of the project I have here the Z value is set to 0 at both the start and the end. Using the different options, none give the desired result.

However, the following option combinations appear to work;

  • Free Smooth and set Both Tangents to Linear
  • Broken and set Both Tangents to Linear

Both of the above increase the appearance of rotation dramatically, changing the Samples from 30 to 15 produces a result which is more in line with the course example.

Hope this helps :slight_smile:

1 Like

Thanks for your time and the info! :slight_smile:

1 Like

No worries, had to update it a moment ago as I’d made a mistake, the above should be correct :slight_smile:

1 Like

Very nice Rob!

I thought that it was indeed the first option that you said, I didn’t know about the Auto/Auto Clamped options, very good to know that these exist!

1 Like

Yeah, these new options appeared in a newer version of Unity than the course was created in, I believe it was Unity 5.5.

Happened to see the issue once before and whilst going through a set of screenshots looking for the differences, this appeared to be the cause. Somehow, that little neuro-pathway in my head stayed connected! :wink:


See also;

1 Like

Nice references! I’m already digging it here. Thanks once again, you are awesome!

1 Like

Privacy & Terms