My Camera and SpringArm aren't being initialized

When i click on the spring arm component and camera component in the blueprint editor it isn’t coming up with any details on the right-hand side and i can’t edit the transform of either components. I think it is because my APawnTurret constructor isn’t getting called, but i don’t know why it isn’t getting called.
Here is my code:



I would appreciate help in solving this problem, oh also for whatever reason changing the values of my movement speed and rotate speed don’t change the speed at which i move or rotate in the game so help with that would also be helpful, i’ve also tried restarting the editor several times after making changes and it doesn’t fix anything

Have you tried closing the editor and reopening it

yes, i have, and it hasn’t done anything

If the constructor wasn’t called I wouldn’t expect to see it. You have the blueprint using the Tank pawn as the base class correct. Maybe try making a new blueprint and see if it persists.

Yeah this is an unreal bug. Has happened with me a couple of times. You might just have to make a new blueprint.

I had some strange things happening with unreal, most of them i restarted unreal or/and refresh visual studio code Project it located under file tab.

making a new blueprint worked, thank you

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.