Lamp Action

I’m not sure if anyone else found this frustrating, but I was having no end of problems with my armature. Each time I tried to parent one of the arms to the armature it would fly off into space in a random direction. In the end I figured there must be some compounded errors from an early stage in creating the armature, so I ended up deleting the entire armature and starting over from scratch. After that it finally worked.

Did anyone else get weird errors, or have an idea what went wrong with my first armature?

in the future you can clear the location, rotation, and scale (or just apply them) and/or select the option to “Keep Transform” when you parent/unparent objects. Mike goes into detail about clearing the rotation, scale, and movement in the lamp section but in short its Alt+G, Alt+R, and Alt+S.

That was the first thing I tried, but I still had problems with multiple arms. When I went back and rebuilt the armature I made sure that I had applied all the rotation and location data from each part, and then I had no problems.

To be honest though, I don’t think that was even the issue. I think that there was an earlier problem in my first armature that was somehow being compounded as I extruded new bones. Either way, the new armature fixed it. I may never know where I went wrong the first time, but it works now.

Thanks for the reply, though, I appreciate the idea.

Privacy & Terms