Is there any reload animation provided in the asset pack(And some more things)

I have been searching for a reload animation for hours to use in my SimpleShooter. Does anyone knows whether there is a reload animation for us to use in the asset pack?

The Animation Starter pack has some I think. Not sure if it works well with the paragon assets.

Check Out Mixamo it has tons of free animations

Also, I use the PlayAnimationMontage to play the reload animation. Just for testing purposes, I used a random AnimMontage from the asset pack. However, it doesn’t seem to be working. Here is my code -
In the .h file(ShooterCharacter) -

UPROPERTY(EditAnywhere)
    UAnimMontage* ReloadAnimMontage;

and in the .cpp file -
PlayAnimMontage(ReloadAnimMontage);
image
As you can see, the ReloadAnimMontage is also selected to play something.
(The AnimMontage is not played though)

And some weird errors in the Output Log -

LogHttp: Warning: 000001B1B7E896C0: invalid HTTP response code received. URL: https://datarouter.ol.epicgames.com/datarouter/api/v1/public/data?SessionID=%7BAF04A940-4A95-AA2D-F7FC-5BBEB6EF219F%7D&AppID=UEEditor.Rocket.Release&AppVersion=4.24.3-11590370%2B%2B%2BUE4%2BRelease-4.24&UserID=723bfaa74fa4b2a7b1eb969576f85f52%7C99f2a5ec6c2e41d18ee0cf5f4e4fe51e%7C32
811b61-a28d-46d2-999a-56ead775d8b8&AppEnvironment=datacollector-binary&UploadType=eteventstream, HTTP code: 0, content length: 0, actual payload size: 0
LogHttp: Warning: 000001B1B7E896C0: request failed, libcurl error: 6 (Couldn't resolve host name)
LogHttp: Warning: 000001B1B7E896C0: libcurl info message cache 0 (Could not resolve host: datarouter.ol.epicgames.com)
LogHttp: Warning: 000001B1B7E896C0: libcurl info message cache 1 (Closing connection 8)
LogHttp: Warning: Retry exhausted on https://datarouter.ol.epicgames.com/datarouter/api/v1/public/data?SessionID=%7BAF04A940-4A95-AA2D-F7FC-5BBEB6EF219F%7D&AppID=UEEditor.Rocket.Release&AppVersion=4.24.3-11590370%2B%2B%2BUE4%2BRelease-4.24&UserID=723bfaa74fa4b2a7b1eb969576f85f52%7C99f2a5ec6c2e41d18ee0cf5f4e4fe51e%7C32811b61-a28d-46d2-999a-56ead775d8b8&AppEnv
ironment=datacollector-binary&UploadType=eteventstream

Ok, so it has been 5 days since this problem, so I am just bumping this post.

Sorry I saw your reply and thought to come back to it after the easier to answer questions and totally forgot.


That message is unrelated
https://answers.unrealengine.com/questions/776250/view.html

Do you have you project somewhere so I could take a look?

1 Like

https://drive.google.com/file/d/1gJSn3wAKwNEBZUvDCrom-Ylz8YaQAaai/view?usp=sharing
Its still in development. My ammo system has a few bugs that I am trying to fix. Its developed on UE 4.24 so you can run it on this version and above.

So in your anim graph you’re going to need to cache the pose
image

Then right click in the graph and search for it (I gave it the name “cache”) and drag off of that and search for “defaultslot”

Then on that change that to match the slot given in anim montage. Which for the one you have selected is “UpperBody” not to be confused with “UpperBodySlot” which is not something I did…

Okay… I did something like this in the AnimGraph -


And selected the Ability_E_Montage as the reload animation for now -
image
And this was autoselected I think, when I check the Ability_E_Montage -

But… animation is still not played. Also, I don’t understand what is caching the pose.

EDIT -
It now seems to be working at least with this code-

EDIT 2 -
It also seems to be working without caching the pose -


So, the questions that remain are -

  1. What is exactly caching?
  2. What is the Slot “UpperBody” used for?
  3. Why did simply making the player play an AnimMontage from code didn’t work? Why we have to include extra code for this?
  4. And. The most important thing, I can’t use the Reload Animation from the AnimStarterPack. I don’t have a reload animation now. Any thoughts on this?
  1. https://en.wikipedia.org/wiki/Cache_(computing)
  2. That would be something the paragon assets setup which I haven’t really delved into.
  3. Honestly I’m not sure I’m not exactly knowledgeable on animations I just followed the docs when searching for a solution
    https://docs.unrealengine.com/en-US/Engine/Animation/AnimHowTo/AdditiveAnimations/index.html
  4. Why can’t you? You might be able to retarget it if that’s the issue
    https://docs.unrealengine.com/en-US/Engine/Animation/AnimationRetargeting/index.html

Okay. I am trying to retarget the animation. But I have a problem. Its just annoying. I can’t click this button in this picture!


Because… OF THIS -

I right click somewhere, and the shortcut menu shows up way above there(Outside of my laptop screen)!
I am stuck on this step. :pensive:

Okay… crisis solved😌. I had a look around in the reload animation I was trying to retarget and found the option. But, some problems yet again. It will be better if a attach a photo for this -


His thumb is cut, enlarged and stretched. His weapon bone is wayyyy out of place.
Help, yet again!

1 Like

What are you talking about? It looks good to me! :stuck_out_tongue:


I guess the fact that the gun is part of the skeletal mesh is messing with it. Does the wraith not come with one? What about the other paragon assets? :confused:

The Waith_Skeleton has two weapon bones, but the UE4_Mannequin_Skeleton has only one. That’s why the weapon bone is so far away.
The thumb issue was caused because I hadn’t set up the Rig correctly. I saw this issue when I visited the skeleton. So that’s solved.
And after that, I seem to also have fixed the problem of the weapon being so far away from the hand, by readjusting it, and then clicking the Add Key button and then clicking Apply -

At last. I seem to have a working animation. But when I play, its a different story. My character just seems to be floating around when reloading. Umm…

Just bumping this post, again.

Sorry about that (again :frowning:).

Any chance you could show a video of that?