Intellisense doesn't fix the squiggles in BullAndCow Game

Hi! I’m trying to set up my VS Code to work with BullAndCow game. I followed the instruction in the lecture VSCode Intellisense Fix, but even after restarting VSCode via UE4, command prompt and VSCode itself the squiggles are still threre. I tried Refresh Visual Studio Code Project via UE4, but it didn’t help.I tried the solution from here but to no avail

I’m using UE4.27 on Windows 10.

Any suggestions how to fix this are highly appreciated!



You don’t need to open VS Code from the dev command prompt anymore. Unreal’s build system already deals with of the compiler stuff so you don’t need to load the environment for it anymore (which is what the devcmd does).

Got it, but what should I do to get rid of those fake errors?

Was kind of hoping that would solve it :sweat_smile:

Did you enable the fixes in the extension’s settings? They’re not enabled by default when installing it.

Yes, I enabled both of them

Could you show the output of the extension?

Open the output window and on the right hand side use the drop down menu to change to the extension’s output.


And it still looks like your original screenshot?

Yes, I still have those squiggles. Since yesterday I’ve written some code in these two files, and it compiles normally, UE4 works fine with this code and fake errors, and it checks some real ones, but Intellisense doesn’t check any other errors even if make them intentionally for test purpose.

Could you try closing VS Code then delete the .vscode folder along with the code-workspace file. After which have Unreal generate the VS Code workspace and re-open.

This will destroy my progress in the game, am I right? Should I first copy somewhere the code itself to save it?

No. Those are files that are only used by vs code.

Your source code is in Source, your assets are in Content and the compiled code is in Binaries and the intermediate files (compiled object files and generated code) are in Intermediate.

Feel free to back it up anyway if you want.

Well, it seems to work! Thank you so much!

If someone needs my experience, here it is. I deleted the .vscode folder and a code-workspace file, then generated the project and opened it via UE4. On the first try I had a list of similar complaints in the output window from C/C++, but I didn’t take a screenshot unfortunately, and also VSCode didn’t load all the variables I added earlier, so they remained white, but the second try was successful I think, no red squiggles, and now Intellisense checks my errors, and also output window is clear now.
image
This line is still white but I suppose it should be white (I didn’t pay attention to it before).

Hi, Are you using a M1 mac for your project? I tried to use one for a short time and hit the exact same problems. I am going to be starting the same course here soon. I’m also wanting to try with the M1 mac again. If you are using the M1 mac has it worked well with the Bull and Cow game?
Thanks
PM