Huge issue after compiling code in Unreal

Hey, I have a headache of a question today :sweat_smile: sorry. So I was having no issue with the first part of getting the door open according to video 98 (and into video 99). But at the end of video 100 I tried to compile and play the game, but then all of these errors popped up. As far as I can see, I did everything the same way as the instructions, so maybe someone else can point out where I messed up?


I’ve been struggling with red squiggles under my #include references, but they work so I’ve just ignored them. Any help is greatly appreciated!

Well the messages don’t match up with the code. Could you try rebuilding by closing Unreal and deleting the Binaries and Intermediate folders?

Ok, I did that and now it won’t open… It has asked me to rebuild it manually. How can I do that?

That means you have compilation errors. Could you provide the log in Saved > Logs?

And the contents off the top one?


Sorry it’s a bit long

You could just post in a preformatted block (</>) here.

Have you changee your code at all? Would need to look at your code at and around line 30 in OpenDoor.cpp

I did comment out the last part of the code in hopes that my issue might have been made clearer earlier on (A little while after creating this post), but that is the only thing I changed. I can change it back if that would help?

Well that’s rather confusing. Talks of string and possible missing * on an FString around line 30 in OpenDoor.cpp but I’m not seeing it.

Could you zip up your project and send it?

I’m not sure that I can, do you know how to do that? I tried to attach the zip file with the upload button, but it doesn’t accept zip files

Yeah you’ll have to use another host like Google Drive.

Found your issue in Some Things Dont Work All of a Sudden

You’re missing a ,

1 Like

Oh sweet!! Yes, I’m pretty sure that should fix my first issue :slight_smile: I still can’t open my unreal building escape file though… Still having the issue of it asking me to build it manually. I don’t mind giving up on it if it’s just too far gone, I’m just happy I know what went wrong now and I wont repeat that issue. I just have to be more careful with deleting folders I guess now haha anyway, if I can get it back, that would be great, but it not then at least I have the answer to my main question.

Well from the sounds of it, it should be realitively easy to remake it?

That would suggest you still have compilation errors and I would need to see the build log to see what’s wrong.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.