[HELP] mono develop wont put in quotation marks

Hey guys i just started out with this course and was ready to put my first step in to coding.
but somehow my monodevelop wont accept it when i pres quotation marks. there simply doesnt happen anything when i press the correct key.

i tried to change the input to simple if i do that it wil put in quotations marks but dont reconise them as a string.

can sombody help.

Hi @Jimmy_Arts

Could you pop a screenshot up to show the issue please.

Having the same problem here-- browsed around the unity forums for possible solutions.

Here is one such solution which has worked for people.

This solution hasn’t worked for me however, hope someone finds out why this is happening.

1 Like

What version(s) of Unity do you currently have installed?

The version specifiek in the course 4.9 runnen on Windows 10

Thats odd, I have used older versions with no issue.

What languages and keyboard inputs do.you have Windows set to?

Not having steps to work with I guess the first thing to do is rule out hardware issues. I also use Windows 10 with mono developer on a standard desktop with a standard keyboard. After that will need steps taken so we can reproduce the issue on our systems to be able to determine if it is a software configuration issue. I am using 4.72 of unity with 4.01 version for Mono developer.

I have the same problem can someone help me out?

thank you very much.

I had the same problem.

#Solution for Windows users :-
here is a possible solutions:

  1. Click the ENG (Language preference button) at the bottom right corner of your task bar.

2.Select a different one from the one which is already selected. (in my case it is English (India) ).

This worked for me…

hope this helps…

I think this might have to do with the automatic typing feature, I know from previous programming experience the quotes don’t show until you type something after the quote mark "and then type and " when you type a quote a second time it shows up, at least that was the case for previous IDE’s I used to code in Java. Try typing quotes twice in a row and see if it shows up. I’ve never used monodevelop however.

Privacy & Terms