Getting MonoDevelop Working Again?

Hello Guys,

Last night I found a tutorial on YouTube for using real world terrain in Unity 5, so, I fired up Unity 5 to see what would happen if I used the terrain from my hometown, more for the lolz than anything else.

So, I got to the part where I had to download a Javascript file from wiki.unity3d.com - ie, create new Javascript file, clicked on the file to open it in MonoDevelop as per usual, and I was presented with a screen where I had the privilege of downloading a 30 day trial version of Microsoft Visual Studio :rage: - ummm, no thanks.

So, I did some searching on how to change it back to MonoDevelop and after doing so was presented with an error, thusly:

Fatal Error

MonoDevelop - Unity Falied to start some of the assemblies required to run Monodevelop - Unity (for example GTK#) may not be properly installed on the GAK.

Please click OK to open the download page, where you can download …​

I have no idea what GAK meant so I looked up GAK: GAK, Gak, or gak may refer to: slang term for methamphetamine, cocaine.

So, I went And downloaded the two files recommended for getting MonoDevelop properly installed on the methamphetamine:

.NET Framework 4.5: Download
GTK# for .NET: Download from mono-project.com

And after installing both products I am still getting the same result. So would someone please point out what I need to do to get MonoDevelop up and running again for the course? I have no idea as to what to do next :confounded:. MonoDevelop is fine on the Unity 4.7 installation that I have on the computer it just stopped working on Unity5 last night.

Thanking you in advance!

Regards.

And you already changed Edit --> Preferences --> External Tools --> External Script Editor?

Yep, that was my first port of call.

I can’t believe it just stopped working and wanted me to try and load a trial version of Microsoft Visual Studio. It was working fine until the Internet cut out last Sunday morning, then yesterday, I finally got the chance to get the terrain data when the Internet came back up and boom … no dice.

I have no idea what to do now?

Addendum:

I also tried uninstalling all the GTK+, Xamarim Studio, and whatever Microsoft Visual Studio components that were floating around on my computer except the NET 4.6 Framework. And then reinstalling Unity 5.5.1f1 and still cannot get MonoDevelop Working.

Now I am starting to get worried.

What should I do?!?

When you install Unity a separate directory with Mono is installed also (per Unity installation) - proven as per your “still working with 4.7” comment etc…

Just out of interest, are you launching (or trying to) Mono from the original/same short-cut icon? If so, it could still be pointing to a directory which is now a little, broken…

Best way to check that would be to browse through to the install path of the version you have just installed, for example;

C:\Program Files\Unity 5.6.0f3\MonoDevelop

there is a “short-cut” icon in this folder, which points to the executable for Mono in the /bin directory.

Try launching Mono individually from the bin directory from the installed 5.5 version and see what happens, maybe there’s a rogue short cut point to the wrong place. Would be worth checking that even after removing it there isn’t anything “left over”. The downside of installing multiple versions of Unity is that Windows only thinks there is “one” version installed (if you check the add/remove programs etc)… so chances are the previous version(s) haven’t been cleanly removed…

See what happens by running Mono directly from the executable and see what happens… if that doesn’t work… make sure you dont lose the 4.7 install (maybe rename it to something else to be sure) and then uninstall it again… clear it right down - and then go check for what’s left…

I’ve not heard of a GAK… I have heard of a GAC… that is related to .Net… it’s the Global Assembly Cache where dlls are registered etc…

About the install path … that’s a great idea I’ll try it out and see what happens!

I’ll get back with the results when I am able!

EDIT:

I tried running MonoDevelop from inside the Unity 5 “directory” structure and no joy, I keep getting the same error message as I do running it from inside Unity!

However, I saw that the MonoDevelop in 5 is running from a ‘shortcut’ for whatever reason so I am going to replace that shortcut with a shortcut pointing to the MonoDevelop that is running in Unity 4.7 and see if that resolves the issue.

No joy!

I get an error messages saying:

  1. InitializeUnityExtensions: must have a valid path for the plugin [17]
  2. Extension was not registered, that means it relies on default UnityExtensions settings, please register extension and apply necessary settings for it in the callback.
  3. InitializeUnityExtensions: Must have a valid path for the plugin [20]

So, I am completely clueless. I am open to any ideas.

wever, I saw that the MonoDevelop in 5 is running from a ‘shortcut’ for whatever reason so I am going to replace that shortcut with a shortcut pointing to the MonoDevelop that is running in Unity 4.7 and see if that resolves the issue.

Hey Vaughan,

Another one of our resident awesome community members (@OboShape) pinged me a message whilst he was on the train which may help with your issue… I’ve had a read through this article and it sounds like it’s certainly something to try;

http://answers.unity3d.com/questions/1224960/mono-develop-unity-failed-to-start-some-of-the-ass.html

I would perhaps start by checking the GTK# stuff, e.g. seeing if it is currently installed on your PC and if it is, then scroll down to the bottom of this article (passed the comment marked as the answer) and try the suggestion by this user Ashike123113, as that seems the most straight forward. Someone has also rather kindly posted a YouTube video with how they managed to resolve the issue also which could be useful.

Kudos to @OboShape if this helps resolve the issue, and if it doesn’t… don’t shoot the messenger :wink:

1 Like

lol the messenger is merely a relay service beep

hope you get it going, if not ill try and break my setup in the same way to try and resolve over the weekend.

1 Like

Privacy & Terms